php5-cli install error - ucfr: Attempt from package php5-cli to take /etc/php5/cli/php.ini away from package php5-fpm

On LMDE when running apt-get install php5-cli or dpkg --configure -a with php5-cli recently installed I received the following error:

ucfr: Attempt from package php5-cli  to take /etc/php5/cli/php.ini away from package php5-fpm
ucfr: Aborting.

Problem was that I had symlinked /etc/php5/cli/php.ini to /etc/php5/fpm/php.ini, which confused the configurator program.

I fixed this by temporarily renaming /etc/php5/cli/php.ini to something else, then run dpkg --configure -a.
It then made a new php.ini in the directory, which I replaced with the symlink previously renamed which was now renamed back to php.ini.

I got more errors, as when running php from terminal it whined about duplicate module loading.
It turned out to be that php-cli loads config from /etc/php5/cli/conf.d. So I renamed that drectory, disabling that feature.

This is a personal note. Last updated: 2014-07-03 10:25:25.



LinkedIn
Klebe.se

Don't forget to pay my friend a visit too. Joakim