Debian 11 - Fortinet Forticlient install - dependency problems

Fortinet Forticlient can be downloaded from:

RPM: https://links.fortinet.com/forticlient/rhel/vpnagent
DEB: https://links.fortinet.com/forticlient/deb/vpnagent

But the deb file cannot be installed in Debian 11 due to dependency problems, when you try you get errors about missing packages libappindicator1 and libgconf-2-4.

libgconf-2-4 can be installed through apt install but libappindicator1 refuses to do so.

Workaround:

apt install libdbusmenu-gtk4 libgconf-2-4

wget http://ftp.us.debian.org/debian/pool/main/libi/libindicator/libindicator7_0.5.0-4_amd64.deb

dpkg -i libindicator7_0.5.0-4_amd64.deb

Download libappindicator1 from https://packages.debian.org/buster/libappindicator1

dpkg -i libappindicator1_0.4.92-7_amd64.deb

Download forticlient from: https://links.fortinet.com/forticlient/deb/vpnagent

(RPM: https://links.fortinet.com/forticlient/rhel/vpnagent)

dpkg -i forticlient_vpn_7.0.0.0018_amd64.deb

Run it:

forticlient


Repository version - outdated version


It is also possible to get an older version by adding the Ubuntu repository to Debian:

wget -O - https://repo.fortinet.com/repo/6.4/ubuntu/DEB-GPG-KEY | sudo apt-key add -

Add the following to /etc/apt/sources.list:
deb [arch=amd64] https://repo.fortinet.com/repo/6.4/ubuntu/ /bionic multiverse

apt update && apt install forticlient


Even newer version


There is an even newer full version than the public download links, 7.0.3, this may be available by your provider.

For this you also need to install more dependencies:

apt install libnss3-tools

This is a personal note. Last updated: 2022-03-16 08:50:14.



LinkedIn
Klebe.se

Don't forget to pay my friend a visit too. Joakim