Debian - E: The package <package> needs to be reinstalled, but I can't find an archive for it

When trying to use apt upgrade the following appears:

E: Paketet <package> måste installeras om, men jag kan inte hitta något arkiv för det.
E: The package <package> needs to be reinstalled, but I can't find an archive for it

Doing apt remove <package> fails with the same error. How shameful.

The solution is to force it to go:

dpkg --remove --force-all <package>

https://askubuntu.com/questions/868064/e-the-package-ubuntu-mono-needs-to-be-reinstalled-but-i-cant-find-an-archive

This is a personal note. Last updated: 2021-10-30 09:29:05.



LinkedIn
Klebe.se

Don't forget to pay my friend a visit too. Joakim